Skip to content

Troubleshooting Server Login

Common causes and solutions for login problems on your vServer.

1. Standard Login Details for the Operating System of a vServer

2. Login via the Screen in the Server Control Panel

3. Login via Remote Connections

4. Frequently Asked Questions (FAQ)

There may be several reasons why you are having trouble logging in to your vServer. See below for some possible causes and solutions. If the problem persists, please contact Customer Support.

1. Standard Login Details for the Operating System of a vServer

We provide our vServers with a Debian operating system by default.

  • The default username is always “root”.
  • You received the password via email after the server was provided.

The password was sent to you in a separate email. This password is different from the one you use to log in to the Server Control Panel or Customer Control Panel.

2. Login via the Screen in the Server Control Panel

You can access your server in the Server Control Panel (SCP) via Screen. If you are using the pre-installed operating system, you can use the default username “root” and the saved password.

Please note the following:

  • For security reasons, entries in the password field are hidden.
  • You cannot copy and paste text.
  • The Keyboard Layout on the screen may differ from the layout on your keyboard. Check in the user field to see if the entries are being transmitted correctly. If this is not the case, adjust the Keyboard Layout under Settings.

3. Login via Remote Connections

Secure Shell (SSH)

Getting Started

  1. First, check whether you can log in to the Server Control Panel (SCP) via Screen. If you cannot log in, the login details you are using may be incorrect.
  2. Also verify that the server has an active internet connection. You can ping your server to check this: ping 1.2.3.4

If the server does not have an active internet connection , go to: Troubleshooting Network Issues

Access via Screen possible and Internet Connection Active

If you can access via the screen and there is an active internet connection, check the following settings:

  • Verify that SSH is active : systemctl status sshd

  • Check whether SSH access is allowed for “root”: /etc/ssh/sshd_config

PermitRootLogin yes > SSH access via the user “root” is allowed.

PermitRootLogin no > SSH access via the user “root” is not allowed.

For security reasons, we recommend creating a separate user for SSH and disabling SSH access via “root”.

  • Check whether the SSH port is open: If an error message such as “Port 22: Connection refused” appears, check whether SSH is running and whether the port is open. It is possible that a firewall is blocking access.

Common Error Messages

  1. Make sure that the login details are correct and that you can log in via the screen.
  2. If not, set a new password in the Server Control Panel (SCP) under Access.

This error message appears when

  • the SSH daemon is not running on the target server.
  • the SSH port is not open. A firewall may be blocking access.

This error message appears when the SSH port on the target server is not open (e.g., due to a firewall) or the server is not configured correctly to accept incoming SSH connections. It may also appear if an individual SSH port has been configured.

This error message appears when the host key of the target server cannot be verified.

This error message appears when user authentication fails. This could be due to an incorrect password or an invalid SSH key, for example.

This error message appears when the SSH key used has an invalid length. To be accepted, the SSH key must meet certain requirements.

This error message appears when the server does not provide any supported authentication methods for the user or the client.

This error message appears when the server does not provide any supported authentication methods for the user or client. This may indicate an issue with the SSH configuration or key generation.

This message appears when the SSH connection is manually disconnected by the user, for example by pressing CTRL+C or closing the terminal window.

Remote Desktop Protocol (RDP)

Please note that RDP is not preinstalled. Therefore, remote access via RDP is only possible if you have installed and configured it yourself.

4. Frequently Asked Questions (FAQ)

If you no longer have access to your server, you can reset it by installing a new operating system. This is equivalent to a complete reset of the server. You can find more information about installing a new operating system here: Server management options

Warning: This will also delete your own data from the server.

If you no longer have access to your Windows server, you can try assigning a new password using the rescue system. Proceed as follows:

  1. Start the server in the rescue system.
  2. Mount the Windows system partition C:\\.
  3. Reset the password using the appropriate tools.

More information: Rescue System

Last update: 23 July 2026